CSRF in Apache Geode
CVE-2025-47410
Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Vulnerability class: CSRF (Cross-Site Request Forgery)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.8 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.004 (29.3th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 29th percentile — 29.3% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.004 · newest: 0.004 · change: 0.000
Affected products
- Apache Geode
- Apache Software Foundation Geode — versions 1.10.0
Weakness classification (CWE)
References
- lists.apache.org/thread/k88tv3rhl4ymsvt4h6qsv7sq10q5prrt (vendor-advisory, Mailing List, Vendor Advisory)
- af854a3a-2127-422b-91ae-364da2661108
Frequently asked questions
- What is CVE-2025-47410?
- CVE-2025-47410 is a high-severity vulnerability in Apache Geode, classified under Cross-Site Request Forgery (CSRF). CVSS score: 8.8/10. Published 2025-10-18.
- How severe is CVE-2025-47410?
- High severity. CVSS v3 base score is 8.8 out of 10.