Vulnerability in Joplin Project
CVE-2025-27134
Joplin is a free, open source note taking and to-do application, which can handle a large number of notes organised into notebooks. Prior to version 3.3.3, a privilege escalation vulnerability exists in the Joplin server, allowing non-admin users to exploit the API endpoint `PATCH /api/users/:id` to set the `is_admin` field to 1. The vulnerability allows malicious low-privileged users to perform administrative actions without proper authorization. This issue has been patched in version 3.3.3.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.8 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.023 (83.0th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 83rd percentile — 83.0% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.022 · newest: 0.023 · change: +0.000
Affected products
- Joplin Project
- Laurent22 Joplin — versions < 3.3.3
Weakness classification (CWE)
Public proof-of-concept exploits
References
Frequently asked questions
- What is CVE-2025-27134?
- CVE-2025-27134 is a high-severity vulnerability in Joplin Project, classified under Improper Access Control. CVSS score: 8.8/10. Published 2025-04-30.
- How severe is CVE-2025-27134?
- High severity. CVSS v3 base score is 8.8 out of 10.
- Is CVE-2025-27134 known to be exploited?
- 2 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.