Privilege escalation in Apache Cassandra

CVE-2025-23015

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Published · last modified .

CVSS v3 metric

CVSS v3 base score 8.8 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

EPSS exploit prediction

EPSS: 0.010 (63.1th percentile), scored .

Low probability of exploitation in the next 30 days, but still tracked. 63rd percentile — 63.1% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2025-23015: held from 0.010 to 0.010.

EPSS over last 30 days · oldest: 0.010 · newest: 0.010 · change: +0.000

Affected products

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2025-23015?
CVE-2025-23015 is a high-severity vulnerability in Apache Cassandra, classified under Privilege Defined With Unsafe Actions. CVSS score: 8.8/10. Published 2025-02-04.
How severe is CVE-2025-23015?
High severity. CVSS v3 base score is 8.8 out of 10.