XSS in Librenms
CVE-2024-49754
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the API-Access page allows authenticated users to inject arbitrary JavaScript through the "token" parameter when creating a new API token. This vulnerability can result in the execution of malicious code in the context of other users' sessions, compromising their accounts and enabling unauthorized actions. This vulnerability is fixed in 24.10.0.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L.
EPSS exploit prediction
EPSS: 0.739 (99.5th percentile), scored .
High probability of exploitation in the next 30 days — patch promptly. 99th percentile — 99.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.724 · newest: 0.739 · change: +0.015
Affected products
- Librenms — versions < 24.10.0
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2024-49754?
- CVE-2024-49754 is a high-severity vulnerability in Librenms, classified under Cross-site Scripting. CVSS score: 7.5/10. Published 2024-11-15.
- How severe is CVE-2024-49754?
- High severity. CVSS v3 base score is 7.5 out of 10.