Vulnerability in Apache Kylin
CVE-2024-23590
Session Fixation vulnerability in Apache Kylin. This issue affects Apache Kylin: from 2.0.0 through 4.x. Users are recommended to upgrade to version 5.0.0 or above, which fixes the issue.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.1 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N.
EPSS exploit prediction
EPSS: 0.007 (51.7th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 52nd percentile — 51.7% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.007 · newest: 0.007 · change: 0.000
Affected products
- Apache Kylin
- Apache Software Foundation Kylin — versions 2.0.0
Weakness classification (CWE)
References
- lists.apache.org/thread/7161154h0k6zygr9917qq0g95p39szml (vendor-advisory, Mailing List, Vendor Advisory)
- af854a3a-2127-422b-91ae-364da2661108 (Mailing List, Third Party Advisory)
Frequently asked questions
- What is CVE-2024-23590?
- CVE-2024-23590 is a critical-severity vulnerability in Apache Kylin, classified under Session Fixation. CVSS score: 9.1/10. Published 2024-11-04.
- How severe is CVE-2024-23590?
- Critical severity. CVSS v3 base score is 9.1 out of 10.