Resource exhaustion in Rabbitmq Rabbitmq-Server
CVE-2023-46118
RabbitMQ is a multi-protocol messaging and streaming broker. HTTP API did not enforce an HTTP request body limit, making it vulnerable for denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish a very large messages over the HTTP API and cause target node to be terminated by an "out-of-memory killer"-like mechanism. This vulnerability has been patched in versions 3.11.24 and 3.12.7.
Vulnerability class: DoS (Denial of Service)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 4.9 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H.
EPSS exploit prediction
EPSS: 0.013 (70.8th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 71st percentile — 70.8% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.011 · newest: 0.013 · change: +0.002
Affected products
- Rabbitmq Rabbitmq-Server — versions < 3.12.7, < 3.11.24
- VMware Rabbitmq
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2023-46118?
- CVE-2023-46118 is a medium-severity vulnerability in Rabbitmq Rabbitmq-Server, classified under Uncontrolled Resource Consumption. CVSS score: 4.9/10. Published 2023-10-25.
- How severe is CVE-2023-46118?
- Medium severity. CVSS v3 base score is 4.9 out of 10.