XSS in Pay Project
CVE-2023-30614
Pay is a payments engine for Ruby on Rails 6.0 and higher. In versions prior to 6.3.2 a payments info page of Pay is susceptible to reflected Cross-site scripting. An attacker could create a working URL that renders a javascript link to a user on a Rails application that integrates Pay. This URL could be distributed via email to specifically target certain individuals. If the targeted application contains a functionality to submit user-generated content (such as comments) the attacker could even distribute the URL using that functionality. This has been patched in version 6.3.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.1 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L.
EPSS exploit prediction
EPSS: 0.004 (39.1th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 39th percentile — 39.1% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.004 · newest: 0.004 · change: 0.000
Affected products
- Pay Project
- Pay-Rails Pay — versions < 6.3.2
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2023-30614?
- CVE-2023-30614 is a high-severity vulnerability in Pay Project, classified under Cross-site Scripting. CVSS score: 7.1/10. Published 2023-04-19.
- How severe is CVE-2023-30614?
- High severity. CVSS v3 base score is 7.1 out of 10.