Privilege escalation in Apache Cassandra
CVE-2023-30601
Privilege escalation when enabling FQL/Audit logs allows user with JMX access to run arbitrary commands as the user running Apache Cassandra This issue affects Apache Cassandra: from 4.0.0 through 4.0.9, from 4.1.0 through 4.1.1. WORKAROUND The vulnerability requires nodetool/JMX access to be exploitable, disable access for any non-trusted users. MITIGATION Upgrade to 4.0.10 or 4.1.2 and leave the new FQL/Auditlog configuration property allow_nodetool_archive_command as false.
Vulnerability class: Privilege Escalation
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.8 (High). Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.003 (28.0th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 28th percentile — 28.0% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.003 · newest: 0.003 · change: 0.000
Affected products
- Apache Cassandra
- Apache Software Foundation Cassandra — versions 4.0.0, 4.1.0
Weakness classification (CWE)
References
- lists.apache.org/thread/f74p9jdhmmp7vtrqd8lgm8bq3dhxl8vn (vendor-advisory, Mailing List)
Frequently asked questions
- What is CVE-2023-30601?
- CVE-2023-30601 is a high-severity vulnerability in Apache Cassandra, classified under Improper Privilege Management. CVSS score: 7.8/10. Published 2023-05-30.
- How severe is CVE-2023-30601?
- High severity. CVSS v3 base score is 7.8 out of 10.