Deserialization in Apache Geode
CVE-2022-37023
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
Vulnerability class: Insecure Deserialization
Published · last modified .
CVSS v3 metric
CVSS v3 base score 6.5 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H.
EPSS exploit prediction
EPSS: 0.018 (78.3th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 78th percentile — 78.3% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.017 · newest: 0.018 · change: +0.001
Affected products
- Apache Geode
- Apache Software Foundation Geode — versions Apache Geode
Weakness classification (CWE)
References
- lists.apache.org/thread/6js89pbqrp52zlpwgry5fsdn76gxbbfj (Mailing List, Vendor Advisory)
Frequently asked questions
- What is CVE-2022-37023?
- CVE-2022-37023 is a medium-severity vulnerability in Apache Geode, classified under Deserialization of Untrusted Data. CVSS score: 6.5/10. Published 2022-08-31.
- How severe is CVE-2022-37023?
- Medium severity. CVSS v3 base score is 6.5 out of 10.