Deserialization in Apache Geode
CVE-2022-37021
Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.
Vulnerability class: Insecure Deserialization
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.8 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.026 (85.6th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 86th percentile — 85.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.026 · newest: 0.026 · change: +0.001
Affected products
- Apache Geode — versions 1.14.0
- Apache Software Foundation Geode — versions Apache Geode
Weakness classification (CWE)
References
- lists.apache.org/thread/qrvhmytsshsk5xcb68pwccw3y6m8o8nr (Mailing List, Vendor Advisory)
Frequently asked questions
- What is CVE-2022-37021?
- CVE-2022-37021 is a critical-severity vulnerability in Apache Geode, classified under Deserialization of Untrusted Data. CVSS score: 9.8/10. Published 2022-08-31.
- How severe is CVE-2022-37021?
- Critical severity. CVSS v3 base score is 9.8 out of 10.