RCE in Apache James
CVE-2022-28220
Apache James prior to release 3.6.3 and 3.7.1 is vulnerable to a buffering attack relying on the use of the STARTTLS command. Fix of CVE-2021-38542, which solved similar problem fron Apache James 3.6.1, is subject to a parser differential and do not take into account concurrent requests.
Vulnerability class: Command Injection (OS Command Injection)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.
EPSS exploit prediction
EPSS: 0.020 (80.6th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 81st percentile — 80.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.020 · newest: 0.020 · change: 0.000
Affected products
- Apache James — versions 3.7.0
- Apache Software Foundation James — versions Apache James
Weakness classification (CWE)
References
- james.apache.org/james/update/2022/08/26/james-3.7.1.html (Patch, Release Notes, Vendor Advisory)
- www.openwall.com/lists/oss-security/2022/09/20/1 (mailing-list, Mailing List, Third Party Advisory)
Frequently asked questions
- What is CVE-2022-28220?
- CVE-2022-28220 is a high-severity vulnerability in Apache James, classified under Command Injection. CVSS score: 7.5/10. Published 2022-09-08.
- How severe is CVE-2022-28220?
- High severity. CVSS v3 base score is 7.5 out of 10.