XSS in Drupal
CVE-2021-41184
jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `of` option of the `.position()` util from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `of` option is now treated as a CSS selector. A workaround is to not accept the value of the `of` option from untrusted sources.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 6.5 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N.
EPSS exploit prediction
EPSS: 0.408 (98.7th percentile), scored .
Moderate probability of exploitation in the next 30 days — watch for active exploitation reports. 99th percentile — 98.7% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.408 · newest: 0.408 · change: 0.000
Affected products
Weakness classification (CWE)
Public proof-of-concept exploits
References
- blog.jqueryui.com/2021/10/jquery-ui-1-13-0-released/ (Release Notes, Vendor Advisory)
- github.com/jquery/jquery-ui/security/advisories/GHSA-gpqq-952q-5327 (Patch, Mitigation, Vendor Advisory)
- github.com/jquery/jquery-ui/commit/effa323f1505f2ce7a324e4f429fa9032c72f280 (Patch, Vendor Advisory)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/… (vendor-advisory, Mailing List, Third Party Advisory)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/… (vendor-advisory, Mailing List, Third Party Advisory)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/… (vendor-advisory, Mailing List, Third Party Advisory)
- www.oracle.com/security-alerts/cpuapr2022.html (Patch, Third Party Advisory)
- security.netapp.com/advisory/ntap-20211118-0004/ (Third Party Advisory)
- www.drupal.org/sa-core-2022-001 (Third Party Advisory)
- www.oracle.com/security-alerts/cpujul2022.html (Third Party Advisory)
Frequently asked questions
- What is CVE-2021-41184?
- CVE-2021-41184 is a medium-severity vulnerability in Drupal, classified under Cross-site Scripting. CVSS score: 6.5/10. Published 2021-10-26.
- How severe is CVE-2021-41184?
- Medium severity. CVSS v3 base score is 6.5 out of 10.
- Is CVE-2021-41184 known to be exploited?
- 14 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.