XSS in Ckeditor

CVE-2021-41164

CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Vulnerability class: XSS (Cross-Site Scripting)

Published · last modified .

CVSS v3 metric

CVSS v3 base score 8.2 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L.

EPSS exploit prediction

EPSS: 0.013 (71.4th percentile), scored .

Low probability of exploitation in the next 30 days, but still tracked. 71st percentile — 71.4% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2021-41164: held from 0.013 to 0.013.

EPSS over last 30 days · oldest: 0.013 · newest: 0.013 · change: 0.000

Affected products

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2021-41164?
CVE-2021-41164 is a high-severity vulnerability in Ckeditor, classified under Cross-site Scripting. CVSS score: 8.2/10. Published 2021-11-17.
How severe is CVE-2021-41164?
High severity. CVSS v3 base score is 8.2 out of 10.