Vulnerability in Apache Kafka

CVE-2021-38153

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Published · last modified .

CVSS v3 metric

CVSS v3 base score 5.9 (Medium). Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N.

EPSS exploit prediction

EPSS: 0.062 (93.5th percentile), scored .

Low probability of exploitation in the next 30 days, but still tracked. 94th percentile — 93.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2021-38153: held from 0.063 to 0.062.

EPSS over last 30 days · oldest: 0.063 · newest: 0.062 · change: -0.001

Affected products

Weakness classification (CWE)

Public proof-of-concept exploits

References

Frequently asked questions

What is CVE-2021-38153?
CVE-2021-38153 is a medium-severity vulnerability in Apache Kafka, classified under Observable Discrepancy. CVSS score: 5.9/10. Published 2021-09-22.
How severe is CVE-2021-38153?
Medium severity. CVSS v3 base score is 5.9 out of 10.
Is CVE-2021-38153 known to be exploited?
2 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.