Vulnerability in Jhy Jsoup

CVE-2021-37714

jsoup is a Java library for working with HTML. Those using jsoup versions prior to 1.14.2 to parse untrusted HTML or XML may be vulnerable to DOS attacks. If the parser is run on user supplied input, an attacker may supply content that causes the parser to get stuck (loop indefinitely until cancelled), to complete more slowly than usual, or to throw an unexpected exception. This effect may support a denial of service attack. The issue is patched in version 1.14.2. There are a few available workarounds. Users may rate limit input parsing, limit the size of inputs based on system resources, and/or implement thread watchdogs to cap and timeout parse runtimes.

Published · last modified .

CVSS v3 metric

CVSS v3 base score 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

EPSS exploit prediction

EPSS: 0.067 (93.9th percentile), scored .

Low probability of exploitation in the next 30 days, but still tracked. 94th percentile — 93.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2021-37714: held from 0.067 to 0.067.

EPSS over last 30 days · oldest: 0.067 · newest: 0.067 · change: 0.000

Affected products

Weakness classification (CWE)

Public proof-of-concept exploits

References

Frequently asked questions

What is CVE-2021-37714?
CVE-2021-37714 is a high-severity vulnerability in Jhy Jsoup, classified under CWE-248. CVSS score: 7.5/10. Published 2021-08-18.
How severe is CVE-2021-37714?
High severity. CVSS v3 base score is 7.5 out of 10.
Is CVE-2021-37714 known to be exploited?
8 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.