Buffer overflow in Apache Hadoop
CVE-2021-37404
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Vulnerability class: Buffer Overflow
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.8 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.030 (87.3th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 87th percentile — 87.3% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.029 · newest: 0.030 · change: +0.001
Affected products
- Apache Hadoop
- Apache Software Foundation Hadoop — versions 2.9.0 to 2.10.1, 3.0.0 to 3.1.4, 3.2.0 to 3.2.2
Weakness classification (CWE)
Public proof-of-concept exploits
References
- lists.apache.org/thread/2h56ztcj3ojc66qzf1nno88vjw9vd4wo (Mailing List)
- security.netapp.com/advisory/ntap-20220715-0007/ (Third Party Advisory)
Frequently asked questions
- What is CVE-2021-37404?
- CVE-2021-37404 is a critical-severity vulnerability in Apache Hadoop, classified under Out-of-bounds Write. CVSS score: 9.8/10. Published 2022-06-13.
- How severe is CVE-2021-37404?
- Critical severity. CVSS v3 base score is 9.8 out of 10.
- Is CVE-2021-37404 known to be exploited?
- 2 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.