XSS in Revive-Adserver Revive Adserver
CVE-2021-22948
Vulnerability in the generation of session IDs in revive-adserver < 5.3.0, based on the cryptographically insecure uniqid() PHP function. Under some circumstances, an attacker could theoretically be able to brute force session IDs in order to take over a specific account.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.1 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N.
EPSS exploit prediction
EPSS: 0.027 (85.9th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 86th percentile — 85.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.027 · newest: 0.027 · change: 0.000
Affected products
- Revive-Adserver Revive Adserver — versions 5.3.0
- Https://github.com/revive-Adserver/revive-Adserver — versions Fixed version v5.3.0
Weakness classification (CWE)
Public proof-of-concept exploits
References
- hackerone.com/reports/1187820 (Exploit, Third Party Advisory)
- www.revive-adserver.com/security/revive-sa-2021-005/ (Patch, Vendor Advisory)
Frequently asked questions
- What is CVE-2021-22948?
- CVE-2021-22948 is a high-severity vulnerability in Revive-Adserver Revive Adserver, classified under Cross-site Scripting. CVSS score: 7.1/10. Published 2021-09-23.
- How severe is CVE-2021-22948?
- High severity. CVSS v3 base score is 7.1 out of 10.
- Is CVE-2021-22948 known to be exploited?
- 2 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.