Vulnerability in Dogtagpki

CVE-2020-15720

In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.

Vulnerability class: Improper Certificate Validation

Published · last modified .

CVSS v3 metric

CVSS v3 base score 6.8 (Medium). Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N.

EPSS exploit prediction

EPSS: 0.010 (62.2th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 62nd percentile — 62.2% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2020-15720: held from 0.010 to 0.010.

EPSS over last 30 days · oldest: 0.010 · newest: 0.010 · change: 0.000

Affected products

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2020-15720?
CVE-2020-15720 is a medium-severity vulnerability in Dogtagpki, classified under Improper Certificate Validation. CVSS score: 6.8/10. Published 2020-07-14.
How severe is CVE-2020-15720?
Medium severity. CVSS v3 base score is 6.8 out of 10.