Use After Free in GNU Gnutls
CVE-2019-3829
A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.
Vulnerability class: Use-After-Free
Published · last modified .
CVSS v3 metric
CVSS v3 base score 5.3 (Medium). Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L.
EPSS exploit prediction
EPSS: 0.590 (99.1th percentile), scored .
High probability of exploitation in the next 30 days — patch promptly. 99th percentile — 99.1% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.590 · newest: 0.590 · change: 0.000
Affected products
- GNU Gnutls
- Gnutls — versions fixed in 3.6.7, affected from 3.5.8
- Fedoraproject Fedora
Weakness classification (CWE)
References
- www.gnutls.org/security-new.html (Exploit, Patch, Vendor Advisory)
- bugzilla.redhat.com/show_bug.cgi (Third Party Advisory, Issue Tracking)
- gitlab.com/gnutls/gnutls/issues/694 (Exploit, Patch, Third Party Advisory)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/… (vendor-advisory)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/… (vendor-advisory)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/… (vendor-advisory)
- security.gentoo.org/glsa/201904-14 (vendor-advisory)
- lists.opensuse.org/opensuse-security-announce/2019-05/msg00017.html (vendor-advisory)
- usn.ubuntu.com/3999-1/ (vendor-advisory)
- security.netapp.com/advisory/ntap-20190619-0004/
Frequently asked questions
- What is CVE-2019-3829?
- CVE-2019-3829 is a medium-severity vulnerability in GNU Gnutls, classified under Use After Free. CVSS score: 5.3/10. Published 2019-03-27.
- How severe is CVE-2019-3829?
- Medium severity. CVSS v3 base score is 5.3 out of 10.