Vulnerability in Canonical Python-Apt
CVE-2019-15795
python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.
Vulnerability class: POODLE (CVE-2014-3566)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 4.7 (Medium). Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N.
EPSS exploit prediction
EPSS: 0.005 (39.2th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 39th percentile — 39.2% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.005 · newest: 0.005 · change: 0.000
Affected products
- Canonical Python-Apt — versions 0.8.3, 0.9.3.5, 1.1.0
- Canonical Ubuntu Linux — versions 12.04, 14.04, 16.04
- Debian Python-Apt — versions 1.8.4
- Ubuntu Python-Apt — versions 0.8.0, 0.8.1, 0.8.3
Weakness classification (CWE)
References
- usn.ubuntu.com/4247-1/ (vendor-advisory, Patch, Vendor Advisory)
- usn.ubuntu.com/4247-3/ (vendor-advisory, Patch, Vendor Advisory)
Frequently asked questions
- What is CVE-2019-15795?
- CVE-2019-15795 is a medium-severity vulnerability in Canonical Python-Apt, classified under Use of a Broken or Risky Cryptographic Algorithm. CVSS score: 4.7/10. Published 2020-03-26.
- How severe is CVE-2019-15795?
- Medium severity. CVSS v3 base score is 4.7 out of 10.