XSS in MediaWiki
CVE-2019-12471
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 6.1 (Medium). Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N.
EPSS exploit prediction
EPSS: 0.013 (69.9th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 70th percentile — 69.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.013 · newest: 0.013 · change: 0.000
Affected products
- MediaWiki
- Debian Linux — versions 9.0
Weakness classification (CWE)
References
- www.debian.org/security/2019/dsa-4460 (vendor-advisory, Third Party Advisory)
- seclists.org/bugtraq/2019/Jun/12 (mailing-list, Mailing List, Third Party Advisory)
- phabricator.wikimedia.org/T207603 (Third Party Advisory)
- lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html (Patch, Third Party Advisory)
Frequently asked questions
- What is CVE-2019-12471?
- CVE-2019-12471 is a medium-severity vulnerability in MediaWiki, classified under Cross-site Scripting. CVSS score: 6.1/10. Published 2019-07-10.
- How severe is CVE-2019-12471?
- Medium severity. CVSS v3 base score is 6.1 out of 10.