Vulnerability in Helm

CVE-2019-1010275

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Vulnerability class: Improper Certificate Validation

Published · last modified .

CVSS v3 metric

CVSS v3 base score 9.8 (Critical). Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

EPSS exploit prediction

EPSS: 0.014 (71.5th percentile), scored .

Low probability of exploitation in the next 30 days, but still tracked. 71st percentile — 71.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2019-1010275: held from 0.014 to 0.014.

EPSS over last 30 days · oldest: 0.014 · newest: 0.014 · change: 0.000

Affected products

  • Helm — versions Before 2.7.2 [fixed: 2.7.2]

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2019-1010275?
CVE-2019-1010275 is a critical-severity vulnerability in Helm, classified under Improper Certificate Validation. CVSS score: 9.8/10. Published 2019-07-17.
How severe is CVE-2019-1010275?
Critical severity. CVSS v3 base score is 9.8 out of 10.