XSS in Apache Tomee
CVE-2018-8031
The Apache TomEE console (tomee-webapp) has a XSS vulnerability which could allow javascript to be executed if the user is given a malicious URL. This web application is typically used to add TomEE features to a Tomcat installation. The TomEE bundles do not ship with this application included. This issue can be mitigated by removing the application after TomEE is setup (if using the application to install TomEE), using one of the provided pre-configured bundles, or by upgrading to TomEE 7.0.5. This issue is resolve in this commit: b8bbf50c23ce97dd64f3a5d77f78f84e47579863.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 6.1 (Medium). Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N.
EPSS exploit prediction
EPSS: 0.020 (80.8th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 81st percentile — 80.8% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.020 · newest: 0.020 · change: 0.000
Affected products
- Apache Tomee
- Apache Software Foundation Tomee — versions < 7.0.5
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2018-8031?
- CVE-2018-8031 is a medium-severity vulnerability in Apache Tomee, classified under Cross-site Scripting. CVSS score: 6.1/10. Published 2018-07-23.
- How severe is CVE-2018-8031?
- Medium severity. CVSS v3 base score is 6.1 out of 10.