Auth bypass in Apache Zookeeper

CVE-2017-5637

Two four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.

Vulnerability class: Broken Authentication

Published · last modified .

CVSS v3 metric

CVSS v3 base score 7.5 (High). Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

EPSS exploit prediction

EPSS: 0.731 (99.5th percentile), scored .

High probability of exploitation in the next 30 days — patch promptly. 99th percentile — 99.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2017-5637: held from 0.731 to 0.731.

EPSS over last 30 days · oldest: 0.731 · newest: 0.731 · change: 0.000

Affected products

Weakness classification (CWE)

Public proof-of-concept exploits

References

Frequently asked questions

What is CVE-2017-5637?
CVE-2017-5637 is a high-severity vulnerability in Apache Zookeeper, classified under Missing Authentication for Critical Function. CVSS score: 7.5/10. Published 2017-10-10.
How severe is CVE-2017-5637?
High severity. CVSS v3 base score is 7.5 out of 10.
Is CVE-2017-5637 known to be exploited?
1 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.