Deserialization in Apache Spark
CVE-2017-12612
In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.
Vulnerability class: Insecure Deserialization
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.8 (High). Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.007 (54.4th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 54th percentile — 54.4% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.007 · newest: 0.007 · change: 0.000
Affected products
- Apache Spark — versions 1.6.0, 1.6.1, 1.6.2
Weakness classification (CWE)
References
- www.securityfocus.com/bid/100823 (VDB Entry, Third Party Advisory, vdb-entry)
- mail-archives.apache.org/mod_mbox/spark-dev/201709.mbox/<CAEccTyy-1yYuhdNgkBUg0… (Mailing List, Vendor Advisory)
Frequently asked questions
- What is CVE-2017-12612?
- CVE-2017-12612 is a high-severity vulnerability in Apache Spark, classified under Deserialization of Untrusted Data. CVSS score: 7.8/10. Published 2017-09-13.
- How severe is CVE-2017-12612?
- High severity. CVSS v3 base score is 7.8 out of 10.