CSRF in Netgate Pfsense

CVE-2017-1000479

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.

Vulnerability class: CSRF (Cross-Site Request Forgery)

Published · last modified .

CVSS v3 metric

CVSS v3 base score 8.8 (High). Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.

EPSS exploit prediction

EPSS: 0.317 (98.3th percentile), scored .

Moderate probability of exploitation in the next 30 days — watch for active exploitation reports. 98th percentile — 98.3% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2017-1000479: held from 0.317 to 0.317.

EPSS over last 30 days · oldest: 0.317 · newest: 0.317 · change: 0.000

Affected products

Weakness classification (CWE)

Public proof-of-concept exploits

References

Frequently asked questions

What is CVE-2017-1000479?
CVE-2017-1000479 is a high-severity vulnerability in Netgate Pfsense, classified under Cross-Site Request Forgery (CSRF). CVSS score: 8.8/10. Published 2018-01-03.
How severe is CVE-2017-1000479?
High severity. CVSS v3 base score is 8.8 out of 10.
Is CVE-2017-1000479 known to be exploited?
1 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.